degraded performance on several features.

Incident Report for DoControl

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue.
Posted May 26, 2025 - 15:22 UTC

Investigating

We noticed a degraded performance around:
identities
posture page
domains inventory
our engineers are investigating and will update.
Posted May 26, 2025 - 09:19 UTC