view google data issue
Incident Report for DoControl
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 10:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 19, 2023 - 09:51 UTC
Investigating
We are currently investigating this issue.
Posted Sep 19, 2023 - 09:30 UTC
This incident affected: Google Apps Drive, Google Apps Docs, Google Apps Sheets, Google Apps Slides and Integrations (Google Workspace).